トップ «前の日記(2007-02-12) 最新 次の日記(2007-02-14)» 編集

2007-02-13 [長年日記]

_ Pear のバージョンをおさらい

取り上げる人が少ないのかな。というか自分があまり真面目に追いかけていないだけか、肝心の情報を結構見落としてたりする。

よく Pear の upgrade でエラーが出るんだけど、とりあえず 1.4.3 くらいに一度上げて、それから上げると。1.4.3 もエラーが出るならまたもうちょっと前のバージョンから上げると。そんな感じかな。

Pear コマンドはいっときミスで 4.2.0 で動かないときがあったけど、1.5.0 以降は公式に 4.3.0 以降を対象とする。個々のパッケージは現時点でも 4.3.0 以降に依存してるもの、4.2.0 でも動くものが混ざっている状態なんだけど、今度はタガが外れたのでどんどん 4.3.0 以降を対象とするようになるのかな。

Tags: PHP PEAR