トップ «前の日記(2009-07-15) 最新 次の日記(2009-07-17)» 編集

2009-07-16 [長年日記]

_ Tunderbird で意図しないアカウント情報が送信される問題が起きた

ある時から突然 Thunderbird で受信時の認証が通らなくなったということでヘルプ。現象としては

  • Thunderbird 側の設定を何か変えたわけではない
  • サーバ側の設定も変更なし
  • 突然認証が通らなくなった

というもの。何度か試してみたけど確かにダメだ。正しいアカウント情報を入れ直したりしてみたけどダメ。

こういうときはログを読む。これ開発でもサポートでも鉄則ね。

……。

Thunderbird の protocol log なんて見た記憶がない。どうやって設定すんだろ? 自分の機械だったら ngrep で強引に読んじゃうんだけど、他人の機械ではそういうわけにもいかない。困ったなぁとつぶやいていたら例によって twitter で正解を知った。

16:19:54 <liar_l> @wtnabe もう遅いっぽいですが、この辺とか。
                  https://wiki.mozilla.org/MailNews:Logging
16:21:01 >wtnabe< @liar_l うぉ。環境変数で採れるんですか!知らなかった。
                  あざっす!

MailNews:Logging - MozillaWiki

ここに代表的なプラットフォームごとにログを採るための環境変数の設定方法が書いてあるのでそれに従うだけ。

17:46:36 >wtnabe< @liar_l ありがとうございます。問題の機械で現象を特定
                  できました。通常の設定画面からは変更できない値が誤っ
                  て使われていたのでabout:configで直しました。
18:02:02 >wtnabe< 探しても出てこない現象だったんでメモ。アカウント設定
                  では一つしかアカウントが見えないのに
                  mail.servers.serverが複数あり、GUI で設定できない
                  usernameが送信されて認証失敗。
18:02:48 >wtnabe< どれか分からないのでusernameを正しいものに全部書き換
                  えて対処。もしかすると使ってないはずのものを消しても
                  よかったのかも。
18:07:29 >wtnabe< OSX だったので log を tail しながらトラブルシュートし
                  たわけど、Windows だったらもっと作業的に面倒だったん
                  だろうな。よかったよ OSX で。

アカウントの作成を失敗してやり直したか、あるいは複数のアカウントを使っていたんだけど消してしまったか、まぁたぶんそんな操作が以前あったのかも。GUI の通常のダイアログでは見えない複数のサーバ情報があり、GUI の通常のダイアログ上には正しい情報が表示されるが、実際には違う情報がサーバに送られてたという、ちょっとやっかいな症状。このトラブルはちょっと経験値要るわ。

上にも書いてあるけど、通常のダイアログで確認できなくても Thunderbird なら about:config の画面で操作できるので今回はそっちで対処。

周りから見ると

  • Mac なのに Terminal でデカデカと log を tail -f
  • いつもの Thunderbird なのに見たことのないウィンドウで文字いっぱい

という状態でとてもいぶかしい感じだった。ま、出張サポセンなんてそんなもの。