トップ «前の日記(2011-08-22) 最新 次の日記(2011-08-25)» 編集

2011-08-23 [長年日記]

_ cutagemをrake0.9.0以降に対応させる

なんか deprecated だよっつって gem が作れなかったので調べてみました。

0.9.0 から

Rake::GemPackageTask is deprecated. Use Gem::PackageTask (require 'rubygems/package_task')

だそうです。

cutagemベースの拙作shlauncherなんかも同様ですが、以下のように書き換えると gem package を作ることができます。

-require 'rake/gempackagetask'
+require 'rubygems/package_task'
-Rake::GemPackageTask.new(spec) do |p|
+Gem::PackageTask.new(spec) do |p|

rubygems の方に Gem::PackageTask が追加されたのはなんと 2009-04-15 だそうで、もう2年半前じゃん…。

Tags: Rubygems Ruby