トップ 最新 追記

2016-02-18 [長年日記]

_ 久しぶりにSinatra AssetPackを触ったらbundle updateしないと動かなかった

※ というか Sinatra AssetPack はメンテナいなくなるよーって話だった。

https://github.com/rstacruz/sinatra-assetpack/issues/197

そうか。考えないとな。

sinatra-assetpack

  1. sinatra入れる
  2. 次にsinatra-assetpack入れる

ってする時に 2 で bundle だけ叩くとダメ。Sinatra AssetPack の方が Sinatra についていけてなくて Tilt が古いものでないと動かないから、みたい。正解はちゃんと

bundle update

すること。

以前試した時には AssetPack がいちばん苦労なく動いたんだけど、他の asset なんとか sprockets なんとかの方がいいのかな。まぁ別に Coffee がどうとかには何もこだわってなくて、単に digest による cache buster が確実に動けばなんでもいいんだけど。

まぁその辺の調査はやるとしてもまた今度。

Tags: Ruby Sinatra